WordPress安裝環境需求

WordPress安裝環境需求

一般人大概不會注意到安裝WordPress需要怎樣的系統環境需求,因為大部分都是租虛擬主機來安裝,而虛擬主機對於WordPress市佔率這麼高的一套CMS內容管理系統照理來說都要能夠支援才對。
不過有些虛擬主機的預設的PHP版本也是比較低的,像是5.3或是5.4,但WordPress官方網站建議是5.6。

為什麼WordPress官網建議使用PHP 5.6?其實可以參考一下PHP官網的這個網頁:http://php.net/supported-versions.php

這頁面有張圖如下:

PHP 版本支援時間圖表

從上圖可以看出,PHP 5.4只支援到 2015年九月,而PHP 5.5只支援到2016年七月四日,也就是本文發表的這天。不支援就表示有什麼安全漏洞也不會再修補了,請改用有支援的5.6或是7.0吧!

有些網站是使用的舊版的PHP製作而成的,他們是不能升級PHP版本,因為升級後,網站就跑不動了。但WordPress沒有這個問題,他有專業團隊在維護更新,能適用於新版的PHP,像是本教學網的WordPress就是運行在PHP7.0的環境。所以看了這篇文章之後,建議趕緊檢查一下自己主機的PHP版本並及時更新吧!如果你是使用cPanel,可以找一個Select PHP Version的選項,如下圖:

cPanel更改PHP版本

點開之後,可以看到目前的版本,並可以變更:

cPanel更改PHP版本

上圖中:

  1. 是現在實際在使用的版本
  2. 下拉選單可以選擇要變更的版本
  3. 下拉選單選好版本後,按下此按鈕儲存設定

下面影片傑克就依照官網的說明來介紹一下WordPress安裝環境需求:



付費/免費會員請登入後觀看Vimeo版無廣告影片


延伸閱讀:
英文網站跟正體中文網站列出的建議需求有些不同

訂閱文章更新電子報

透過WordPress.com平台(jetpack功能)訂閱文章更新電子報

這個網站採用 Akismet 服務減少垃圾留言。進一步瞭解 Akismet 如何處理網站訪客的留言資料